>

火狐浏览器安装adobe

- 编辑:正版管家婆马报彩图 -

火狐浏览器安装adobe

centos6.2安装Opera

今天想要在linux下上网看个电影,结果打开浏览器,提示没有安装flash player插件,点击自动安装,却提示系统不支持最新版本的插件,我的系统是用的RHEL 5.5。没办法,google一番,下载到一个软件包install_flash_player_11_linux.i386.tar.gz。
install_flash_player_11_linux.i386.tar.gz下载地址:
安装方法如下,做个总结:将软件包解压:
[[email protected] /]# tar zxvf install_flash_player_11_linux.i386.tar.gz /tmp/flashplayer
[[email protected] /]# ls /tmp/flashplayerlinux
usr libflashplayer.so
我们看到解压出来的东西有个usr文件夹,一个库文件。库文件需要放在火狐浏览器安装插件的路径下。但当时我不知道这个路径。搜索一下:
[[email protected] /]# find /usr/ -name firefox
/usr/lib/firefox-3.0.18/firefox
切换到这个路径看到firefox是个文件,不是目录,并没有找到plugin的路径。继续搜索,换一个关键词mozilla:
[[email protected] /]# find /usr -name mozilla
/usr/lib/mozilla
/usr/share/mozilla
看这次搜索结果,切换到/usr/lib/mozilla/下,果然在这里
[[email protected] /]# cd /usr/lib/mozilla/
[[email protected] /]# ls
extensions plugins plugins-wrapped
[[email protected] /]#
好了,这下就可以执行下面的操作了:
[[email protected] /]# cp /tmp/flashplayer/libflashplayer.so /usr/lib/mozilla/plugins/ -rf
[[email protected] /]# chmod 755 /usr/lib/mozilla/plugins/libflashplayer.so
[[email protected] /]# cp /tmp/flashplayer/usr/* /usr/ -rf
偷了个懒,直接给libflashplayer.so赋755的权限。
这样就已经安装完毕,然后重启Mozilla firefox就可以啦!!

 

再来个CentOS 6.3 为Firefox安装Flash插件教程

不是自己不想安装Chrome, 只是,实在安装不了。

下载install_flash_player_11_linux.i386.tar.gz打包文件到本地终端进入install_flash_player_11_linux.i386.tar.gz所在目录使用命令tar -zxvf 解压install_flash_player_11_linux.i386.tar.gz文件tar -zxvf install_flash_player_11_linux.i386.tar.gz解压后是一个 libflashplayer.so和一个usr文件夹#ln -s /usr/lib/nspluginwrapper/noarch/npviewer /usr/bin/npviewer#sh /etc/sysconfig/nspluginwrapper -v -i /libflashplayer.so所在路径/libflashplayer.so#cp /libflashplayer.so所在路径/libflashplayer.so /usr/lib/mozilla/plugins# sh /etc/sysconfig/nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so#sh /etc/sysconfig/nspluginwrapper -l重启firefox浏览器 在地址栏里输入 about:plugins查看flash插件信息注:下载flash player插件源文件地址

 

player插件,点击自动安装,却提示系统不支持最新版本的插件,我的...

下载Opera

 

wget

 

解压

 

tar -jxf opera-12.00-1467.i386.linux.tar.bz2

 

./install 

 

一路Enter

 

成功安装 。

图片 1  

注意,去到官网 fomat, 要用tar.bz2,不然,下载的rpm包,

 

会出现如下错误

 

[[email protected] File]$ rpm -ivh opera-12.00-1467.i386.rpm 

error: Failed dependencies:

rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by opera-12.00-1467.i386

安装chrome的rpm包也是这样,不知怎么解决~

 

为了能使Opera支持flash, 把解压后的 

 

1.下载插件

flashplayer10_2_p3_64bit_linux_111710.tar.gz

 

2.安装插件

1)解压文件flashplayer10_2_p3_64bit_linux_111710.tar.gz,得到libflashplayer.so

2)在终端执行命令:

$ mkdir -p ~/.opera/plugins

$ cp 下载/install_flash_player_10_linux/libflashplayer.so ~/.opera/plugins

 

重启Opera就行啦^_^.

 

不是自己不想安装Chrome, 只是,实在安装不了。 下载Opera wget ...

本文由正版管家婆马报彩图发布,转载请注明来源:火狐浏览器安装adobe